Naming Convention for Mobile Services ?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Naming Convention for Mobile Services ?

Chris Foley
Hi All,

I had a brief discussion with John around Naming Conventions and what may be worth putting in place which could be beneficial but not restrictive. I wanted to kick start discussion on this around what may be worthwhile.

An important aspect of 5.x is the value add services and getting these in place and discoverable from Mobile Core. Should we be applying some naming convention or mandatory attributes to these services?

Attributes / Properties of a Service, e.g. ;
----------------------------------------------
Display Name: Push Notifications
id / serviceName: push
APB Label/Tag: mobile-service
Would it be any benefit if the APB tag (mobile-service) carried over and became a label on the OCP service (e.g. for the Core SDK to read what Mobile Services are available in a namespace)?
APB Integrations: <list of service ids of the services this service integrates with>

Some of the above may be agreed already!

We should agree on the actual serviceNames (interested to hear the Mobile Service Teams view on what the names should be):
Metrics = metrics
Push Notifications = push
Data Synchronisation = sync
Security & Identity Management = keycloak
Mobile Build Automation = build
API Gateway = gateway

Are there other naming aspects which could be worthwhile getting agreement on? Around the SDKs, as they are being designed now, it is probably worth considering also.

All opinions welcome.

Best Regards,
Chris.
--

CHRISTOPHER FOLEY

BUSINESS SYSTEMS ANALYST, MOBILE

Red Hat Ireland

Communications House, Cork Road,

Waterford City, Ireland X91NY33

[hidden email]   


_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
Reply | Threaded
Open this post in threaded view
|

Re: Naming Convention for Mobile Services ?

Matthias Wessendorf

On Wed 10. Jan 2018 at 12:45, Chris Foley <[hidden email]> wrote:
Hi All,

I had a brief discussion with John around Naming Conventions and what may be worth putting in place which could be beneficial but not restrictive. I wanted to kick start discussion on this around what may be worthwhile.

An important aspect of 5.x is the value add services and getting these in place and discoverable from Mobile Core. Should we be applying some naming convention or mandatory attributes to these services?

Attributes / Properties of a Service, e.g. ;
----------------------------------------------
Display Name: Push Notifications
id / serviceName: push
APB Label/Tag: mobile-service
Would it be any benefit if the APB tag (mobile-service) carried over and became a label on the OCP service (e.g. for the Core SDK to read what Mobile Services are available in a namespace)?
APB Integrations: <list of service ids of the services this service integrates with>

Some of the above may be agreed already!

We should agree on the actual serviceNames (interested to hear the Mobile Service Teams view on what the names should be):
Metrics = metrics
Push Notifications = push
Data Synchronisation = sync
Security & Identity Management = keycloak
Mobile Build Automation = build
API Gateway = gateway


+1 they are short and easy (in contrast to previous fh-sync(-server)




Are there other naming aspects which could be worthwhile getting agreement on? Around the SDKs, as they are being designed now, it is probably worth considering also.

All opinions welcome.

Best Regards,
Chris.
--

CHRISTOPHER FOLEY

BUSINESS SYSTEMS ANALYST, MOBILE

Red Hat Ireland

Communications House, Cork Road,

Waterford City, Ireland X91NY33

[hidden email]   

_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
--
Project lead AeroGear.org

_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
Reply | Threaded
Open this post in threaded view
|

Re: Naming Convention for Mobile Services ?

Matthias Wessendorf
In reply to this post by Chris Foley
hey chris,

the aerogear list address is "[hidden email]"  not @redhat 

On Wed, Jan 10, 2018 at 12:44 PM, Chris Foley <[hidden email]> wrote:
Hi All,

I had a brief discussion with John around Naming Conventions and what may be worth putting in place which could be beneficial but not restrictive. I wanted to kick start discussion on this around what may be worthwhile.

An important aspect of 5.x is the value add services and getting these in place and discoverable from Mobile Core. Should we be applying some naming convention or mandatory attributes to these services?

Attributes / Properties of a Service, e.g. ;
----------------------------------------------
Display Name: Push Notifications
id / serviceName: push
APB Label/Tag: mobile-service
Would it be any benefit if the APB tag (mobile-service) carried over and became a label on the OCP service (e.g. for the Core SDK to read what Mobile Services are available in a namespace)?
APB Integrations: <list of service ids of the services this service integrates with>

Some of the above may be agreed already!

We should agree on the actual serviceNames (interested to hear the Mobile Service Teams view on what the names should be):
Metrics = metrics
Push Notifications = push
Data Synchronisation = sync
Security & Identity Management = keycloak
Mobile Build Automation = build
API Gateway = gateway

Are there other naming aspects which could be worthwhile getting agreement on? Around the SDKs, as they are being designed now, it is probably worth considering also.

All opinions welcome.

Best Regards,
Chris.
--

CHRISTOPHER FOLEY

BUSINESS SYSTEMS ANALYST, MOBILE

Red Hat Ireland

Communications House, Cork Road,

Waterford City, Ireland X91NY33

[hidden email]   


_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev




--
Project lead AeroGear.org

_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
Reply | Threaded
Open this post in threaded view
|

Re: Naming Convention for Mobile Services ?

pwright
In reply to this post by Chris Foley

Hi Chris,

thanks for starting this discussion, can I object to one item:

Security & Identity Management = keycloak

because this is likely to end up in downstream documentation, we should avoid names of upstream projects. In this case I hope we can use something like 'identity' instead?

Paul


On 01/10/2018 11:44 AM, Chris Foley wrote:
Hi All,

I had a brief discussion with John around Naming Conventions and what may be worth putting in place which could be beneficial but not restrictive. I wanted to kick start discussion on this around what may be worthwhile.

An important aspect of 5.x is the value add services and getting these in place and discoverable from Mobile Core. Should we be applying some naming convention or mandatory attributes to these services?

Attributes / Properties of a Service, e.g. ;
----------------------------------------------
Display Name: Push Notifications
id / serviceName: push
APB Label/Tag: mobile-service
Would it be any benefit if the APB tag (mobile-service) carried over and became a label on the OCP service (e.g. for the Core SDK to read what Mobile Services are available in a namespace)?
APB Integrations: <list of service ids of the services this service integrates with>

Some of the above may be agreed already!

We should agree on the actual serviceNames (interested to hear the Mobile Service Teams view on what the names should be):
Metrics = metrics
Push Notifications = push
Data Synchronisation = sync
Security & Identity Management = keycloak
Mobile Build Automation = build
API Gateway = gateway

Are there other naming aspects which could be worthwhile getting agreement on? Around the SDKs, as they are being designed now, it is probably worth considering also.

All opinions welcome.

Best Regards,
Chris.
--

CHRISTOPHER FOLEY

BUSINESS SYSTEMS ANALYST, MOBILE

Red Hat Ireland

Communications House, Cork Road,

Waterford City, Ireland X91NY33

[hidden email]   



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev

-- 
Paul Wright
Mobile Docs (github: finp)

_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
Reply | Threaded
Open this post in threaded view
|

Re: Naming Convention for Mobile Services ?

John Frizelle
Agree that "Security & Identity Management" should not be "keycloak"

Suggest we use "auth" or "security" instead.

@Joe - I would hope that we could come up with names that work both upstream and downstream. Which ones would you have questions/concerns about?

--
John Frizelle
Chief Architect, Red Hat Mobile
Consulting Engineer

mobile: <a href="tel://+353872901644" target="_blank">+353 87 290 1644
twitter: @johnfriz
skype: john_frizelle




On 11 January 2018 at 09:35, Paul Wright <[hidden email]> wrote:

Hi Chris,

thanks for starting this discussion, can I object to one item:

Security & Identity Management = keycloak

because this is likely to end up in downstream documentation, we should avoid names of upstream projects. In this case I hope we can use something like 'identity' instead?

Paul


On 01/10/2018 11:44 AM, Chris Foley wrote:
Hi All,

I had a brief discussion with John around Naming Conventions and what may be worth putting in place which could be beneficial but not restrictive. I wanted to kick start discussion on this around what may be worthwhile.

An important aspect of 5.x is the value add services and getting these in place and discoverable from Mobile Core. Should we be applying some naming convention or mandatory attributes to these services?

Attributes / Properties of a Service, e.g. ;
----------------------------------------------
Display Name: Push Notifications
id / serviceName: push
APB Label/Tag: mobile-service
Would it be any benefit if the APB tag (mobile-service) carried over and became a label on the OCP service (e.g. for the Core SDK to read what Mobile Services are available in a namespace)?
APB Integrations: <list of service ids of the services this service integrates with>

Some of the above may be agreed already!

We should agree on the actual serviceNames (interested to hear the Mobile Service Teams view on what the names should be):
Metrics = metrics
Push Notifications = push
Data Synchronisation = sync
Security & Identity Management = keycloak
Mobile Build Automation = build
API Gateway = gateway

Are there other naming aspects which could be worthwhile getting agreement on? Around the SDKs, as they are being designed now, it is probably worth considering also.

All opinions welcome.

Best Regards,
Chris.
--

CHRISTOPHER FOLEY

BUSINESS SYSTEMS ANALYST, MOBILE

Red Hat Ireland

Communications House, Cork Road,

Waterford City, Ireland X91NY33

[hidden email]   



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev

-- 
Paul Wright
Mobile Docs (github: finp)

_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
Reply | Threaded
Open this post in threaded view
|

Re: Naming Convention for Mobile Services ?

Wei Li
+1. I prefer `auth` as `security` is too vague.

On Thu, Jan 11, 2018 at 2:28 PM, John Frizelle <[hidden email]> wrote:
Agree that "Security & Identity Management" should not be "keycloak"

Suggest we use "auth" or "security" instead.

@Joe - I would hope that we could come up with names that work both upstream and downstream. Which ones would you have questions/concerns about?

--
John Frizelle
Chief Architect, Red Hat Mobile
Consulting Engineer

mobile: <a href="tel://+353872901644" target="_blank">+353 87 290 1644
twitter: @johnfriz
skype: john_frizelle




On 11 January 2018 at 09:35, Paul Wright <[hidden email]> wrote:

Hi Chris,

thanks for starting this discussion, can I object to one item:

Security & Identity Management = keycloak

because this is likely to end up in downstream documentation, we should avoid names of upstream projects. In this case I hope we can use something like 'identity' instead?

Paul


On 01/10/2018 11:44 AM, Chris Foley wrote:
Hi All,

I had a brief discussion with John around Naming Conventions and what may be worth putting in place which could be beneficial but not restrictive. I wanted to kick start discussion on this around what may be worthwhile.

An important aspect of 5.x is the value add services and getting these in place and discoverable from Mobile Core. Should we be applying some naming convention or mandatory attributes to these services?

Attributes / Properties of a Service, e.g. ;
----------------------------------------------
Display Name: Push Notifications
id / serviceName: push
APB Label/Tag: mobile-service
Would it be any benefit if the APB tag (mobile-service) carried over and became a label on the OCP service (e.g. for the Core SDK to read what Mobile Services are available in a namespace)?
APB Integrations: <list of service ids of the services this service integrates with>

Some of the above may be agreed already!

We should agree on the actual serviceNames (interested to hear the Mobile Service Teams view on what the names should be):
Metrics = metrics
Push Notifications = push
Data Synchronisation = sync
Security & Identity Management = keycloak
Mobile Build Automation = build
API Gateway = gateway

Are there other naming aspects which could be worthwhile getting agreement on? Around the SDKs, as they are being designed now, it is probably worth considering also.

All opinions welcome.

Best Regards,
Chris.
--

CHRISTOPHER FOLEY

BUSINESS SYSTEMS ANALYST, MOBILE

Red Hat Ireland

Communications House, Cork Road,

Waterford City, Ireland X91NY33

[hidden email]   



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev

-- 
Paul Wright
Mobile Docs (github: finp)

_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev




--

WEI LI

SENIOR SOFTWARE ENGINEER

Red Hat Mobile

[hidden email]    M: <a href="tel:+353862393272" style="color:rgb(0,136,206);font-size:11px;margin:0px" target="_blank">+353862393272    


_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
Reply | Threaded
Open this post in threaded view
|

Re: Naming Convention for Mobile Services ?

Massimiliano Ziccardi
Agree with Wei for `auth` instead of `keycloak` or `security`

On Thu, Jan 11, 2018 at 9:58 PM, Wei Li <[hidden email]> wrote:
+1. I prefer `auth` as `security` is too vague.

On Thu, Jan 11, 2018 at 2:28 PM, John Frizelle <[hidden email]> wrote:
Agree that "Security & Identity Management" should not be "keycloak"

Suggest we use "auth" or "security" instead.

@Joe - I would hope that we could come up with names that work both upstream and downstream. Which ones would you have questions/concerns about?

--
John Frizelle
Chief Architect, Red Hat Mobile
Consulting Engineer

mobile: <a href="tel://+353872901644" target="_blank">+353 87 290 1644
twitter: @johnfriz
skype: john_frizelle




On 11 January 2018 at 09:35, Paul Wright <[hidden email]> wrote:

Hi Chris,

thanks for starting this discussion, can I object to one item:

Security & Identity Management = keycloak

because this is likely to end up in downstream documentation, we should avoid names of upstream projects. In this case I hope we can use something like 'identity' instead?

Paul


On 01/10/2018 11:44 AM, Chris Foley wrote:
Hi All,

I had a brief discussion with John around Naming Conventions and what may be worth putting in place which could be beneficial but not restrictive. I wanted to kick start discussion on this around what may be worthwhile.

An important aspect of 5.x is the value add services and getting these in place and discoverable from Mobile Core. Should we be applying some naming convention or mandatory attributes to these services?

Attributes / Properties of a Service, e.g. ;
----------------------------------------------
Display Name: Push Notifications
id / serviceName: push
APB Label/Tag: mobile-service
Would it be any benefit if the APB tag (mobile-service) carried over and became a label on the OCP service (e.g. for the Core SDK to read what Mobile Services are available in a namespace)?
APB Integrations: <list of service ids of the services this service integrates with>

Some of the above may be agreed already!

We should agree on the actual serviceNames (interested to hear the Mobile Service Teams view on what the names should be):
Metrics = metrics
Push Notifications = push
Data Synchronisation = sync
Security & Identity Management = keycloak
Mobile Build Automation = build
API Gateway = gateway

Are there other naming aspects which could be worthwhile getting agreement on? Around the SDKs, as they are being designed now, it is probably worth considering also.

All opinions welcome.

Best Regards,
Chris.
--

CHRISTOPHER FOLEY

BUSINESS SYSTEMS ANALYST, MOBILE

Red Hat Ireland

Communications House, Cork Road,

Waterford City, Ireland X91NY33

[hidden email]   



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev

-- 
Paul Wright
Mobile Docs (github: finp)

_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev




--

WEI LI

SENIOR SOFTWARE ENGINEER

Red Hat Mobile

[hidden email]    M: <a href="tel:+353862393272" style="color:rgb(0,136,206);font-size:11px;margin:0px" target="_blank">+353862393272    


_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev