oc cluster up - router not starting

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

oc cluster up - router not starting

Jan Hellar
Hi,

recently I wanted to install MCP on mac. I followed installation guide for mcp-standalone [1]. Ansible playbook fails when it waits for oc cluster to become ready. When running `oc cluster status` I get `Notice: Router is not yet ready`. I have also tried to run `oc cluster up` manually - same issue. When running `oc get pods` in `default` project, I can see that pod for router is in ContainerCreating state. Looking at events for the router pod I can see these two events:
- Sandbox changed - Pod sandbox changed, it will be killed and re-created. 12 times in the last minute
-  Failed sync - Error syncing pod - 13 times in the last minute

I have latest version of docker installed (Version 17.09.0-ce-mac35 (19611)). Tried latest version (3.6.0) of openshift-cli from both github and brew.

Can anybody help with this issue? Thank you.

Best regards,


_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev
Reply | Threaded
Open this post in threaded view
|

Re: oc cluster up - router not starting

John Frizelle
Hi Jan,

This seems to be an OpenShift problem rather than something specific to mobile.

Suggest you ask the question on an OpenShift list - (i.e. with references to MCP removed and just focused on the fact that oc cluster up is not working

Regards,
John.


--
John Frizelle
Chief Architect, Red Hat Mobile
Consulting Engineer

mobile: <a href="tel://+353872901644" target="_blank">+353 87 290 1644
twitter: @johnfriz
skype: john_frizelle




On 25 October 2017 at 12:56, Jan Hellar <[hidden email]> wrote:
Hi,

recently I wanted to install MCP on mac. I followed installation guide for mcp-standalone [1]. Ansible playbook fails when it waits for oc cluster to become ready. When running `oc cluster status` I get `Notice: Router is not yet ready`. I have also tried to run `oc cluster up` manually - same issue. When running `oc get pods` in `default` project, I can see that pod for router is in ContainerCreating state. Looking at events for the router pod I can see these two events:
- Sandbox changed - Pod sandbox changed, it will be killed and re-created. 12 times in the last minute
-  Failed sync - Error syncing pod - 13 times in the last minute

I have latest version of docker installed (Version 17.09.0-ce-mac35 (19611)). Tried latest version (3.6.0) of openshift-cli from both github and brew.

Can anybody help with this issue? Thank you.

Best regards,


_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev



_______________________________________________
feedhenry-dev mailing list
[hidden email]
https://www.redhat.com/mailman/listinfo/feedhenry-dev